Latest News

Adobe has recently released security updates to fix two critical vulnerabilities for Acrobat and Reader. The first vulnerability, identified as CVE-2018-16011, can lead to the execution of arbitrary code. The second vulnerability, identified as CVE-2018-19725, can result in privilege escalation.

As these vulnerabilities are public now, it is highly recommended that both Mac and Windows users install these updates. Click on the following link for further action:

https://helpx.adobe.com/security/products/acrobat/apsb19-02.html